A bad firmware update appears to have broken the trackpad on the Logitech Combo Touch accessory for the Apple iPad. Both iPad Pro and iPad Air have been affected by the issue.

And as a result, there have been plenty of complaints regarding the issue on official Apple forums as well as on MacRumors forums. Some of them have been given below.

Logitech Combo Touch trackpad issue

I just installed the latest firmware for my Logitech Combo Touch for iPad Pro 10.5, and the trackpad no longer works. The keys still work. Reconnecting the keyboard and rebooting the iPad did not resolve this. I’m running iPadOS 14. Is anyone else with this keyboard experiencing this issue?

Same issue with my iPad Air (2019) – did the firmware update as well as the ipadOS update. Keys work, but the trackpad doesn’t. Tried the usual remedies (clean connectors, restart ipad etc.) to no avail.

As apparent from the above, users report that the latest firmware for Logitech Combo Touch causes the accessory’s trackpad to stop working. However, its keys continue to work just fine.

Moreover, reconnecting the keyboard and rebooting the iPad does not help with the issue at all which only reiterates that the update did indeed break the trackpad.

Another possible explanation could be that the firmware update was interrupted resulting in corrupt software, at least according to this user.

ipad 7th gen

The bug also seems to have been present for quite some time now with the first report dating back to September.

It is unclear as of now if iPadOS has anything to do with the issue as the first reports have coincided with iPadOS 14 release. This assumption isn’t exactly far fetched though.

If you are one of the users facing this issue, then worry not, for we got a fix for you.

Workaround for the Logitech Combo Touch trackpad not working issue

Just follow the no-brainer steps given below by “Logi_Richard” on the Apple forums. This has worked for several users.

logitech trackpad issue fix

Make sure that you use the on-screen keyboard, though, and not the one on the Logitech Combo Touch.

Hopefully, this fixed the problem for you. Let us know in the comments below if it did. Be sure to also check out our dedicated iPadOS 14 bug tracker for further coverage on issues like these.

PiunikaWeb started as purely an investigative tech journalism website with main focus on ‘breaking’ or ‘exclusive’ news. In no time, our stories got picked up by the likes of Forbes, Foxnews, Gizmodo, TechCrunch, Engadget, The Verge, Macrumors, and many others. Want to know more about us? Head here.

Zohaib Ahmed
824 Posts

Simply love being surrounded by technology as it's a constant reminder of how far humans have advanced as a race. Every new development feels exciting, which I convey to others through writing. And after a day's work, gaming just feels therapeutic.

Next article View Article

[Up: NewTumbl shut down] Is Tumblr shutting down? No. But there’s exodus and Newgrounds is gaining from it

NOTE: For all latest, breaking news related to Tumblr adult content ban as well as its alternatives, head here. So it's been nearly a week since Tumblr started experiencing...
Jun 13, 2023 4 Min Read