Elgato audio issues with VST plugin for Wave Link get acknowledged, fix in the works (workaround inside)

Owned by Corsair Gaming Inc, Elgato is a brand of consumer electronics that was founded in 2010. In case you are wondering, it is the same company that makes the Stream Deck.

They also manufacture other products such as microphones, green screens, and SSDs to name a few. Having said that, Elgato has a dedicated software for microphones called Wave Link.

Elgato-Wave-link

The application allows users to mix up to eight audio sources and create two separate outputs. The developers frequently update the application with new features and improve existing ones.

Having said that, streamers who use Elgato Wave Link are now facing an issue with the new Nvidia Broadcast VST plugin (1,2,3,4,5).

It looks like users are reportedly having all sorts of problems ranging from the game stuttering to some having no audio.

Elgato-Wave-link-VST-plugin-audio-issues
Source

I’m in the camp of people who’ve been having trouble with the VST plugin – my specific issue is that, so long as the VST is active in Wave Link, any audio that goes through a Wave Link virtual cable experiences little skips and stutters, or being muted for a split second.

I am on an Asus Strix 3080Ti and this even occurs under very little GPU load, just decoding a youtube video without playing a game, or even with no decoding and I’m just using spotify. This happens even if I set wave link’s buffer size to Very Large.
(Source)

The RTX Voice VST has been super buggy for me. When I initially load it on to a channel, it will crash Wave Link, and sometimes I have to restart Wave Link a few times before it recognizes that I have the required resources downloaded.

Additionally, when entering into any fullscreen game, my audio completely breaks, crackling on both my headphones and the audio delivered through my microphone to discord. As soon as I removed RTX Voice from the channel everything was fixed.
(Source)

Fortunately, Elgato support has acknowledged that the Wave Link VST plugin is causing audio issues and said the developers are working on a fix.

Elgato-Wave-link-VST-plugin-audio-issues-acknowledgement
Source

Until then, those having problems with the plugin can try disabling Nvidia Broadcast VST since it is helping many with the problem.

Can confirm, that disabling nvidia broadcast vst immediately solves the issue of lagging/popping audio. No problems while using standalone nvidia broadcast software though.
(Source)

If the aforementioned workaround helped fix the audio issues, do let us know in the comments down below. Also, we will be updating this space once the problem is resolved so stay tuned for more information.

Note: We have more such stories in our dedicated News section so be sure to follow them as well.

Featured image source: Elgato

PiunikaWeb started as purely an investigative tech journalism website with main focus on ‘breaking’ or ‘exclusive’ news. In no time, our stories got picked up by the likes of Forbes, Foxnews, Gizmodo, TechCrunch, Engadget, The Verge, Macrumors, and many others. Want to know more about us? Head here.

Want to work for PiunikaWeb and enjoy best-in-industry compensation & benefits? You'll be glad to know we're hiring experienced candidates.

Anurag Chawake

My fascination with technology and computers goes back to the days of Windows XP. Since then, I have been tinkering with OS, mobile phones, and other things. When I am not working on anything, you will find me enjoying video games on some Discord server.